Back to overview
Degraded
Genoguard generation is not working as expected
Jun 07 at 03:05pm BST
Affected services
cellrepo.com
Resolved
Jun 13 at 11:55am BST
Genoguard generation bug resolved
Affected services
cellrepo.com
Created
Jun 07 at 03:05pm BST
We are aware of this issue and are working on a fix, once resolved, CellRepo status will be updated to reflect this
Affected services
cellrepo.com